POJ 1979---B - 廣搜/深搜 基礎

                     
B - 廣搜/深搜 基礎
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

//@author:yzj   Date:2015/07/25
//sourse:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=824
//meaning:找出最多可以到達的'.'
#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;
const int  MAXN  = 25;
int w, h;
char c[MAXN][MAXN];
int sx, sy, cnt;
int dx[4]={-1, 0, 1, 0};
int dy[4]={0, 1, 0, -1};

void dfs(int x, int y)
{
    cnt++;
    c[x][y]='#';
    for(int i = 0; i < 4; i++)
    {
        int nx = x+dx[i], ny = y+dy[i];
        //這裏其實nx代表行,最多有h行,ny代表隊的是列,最多有w列,不要搞混了
        if(0<=nx&&nx<h&&0<=ny&&ny<w&&c[nx][ny]=='.')
        {
            dfs(nx, ny);
        }
    }
}

int main()
{
    、、freopen("i:/yzj/cppCode/input.txt", "r", stdin);
    while(scanf("%d %d", &w, &h) && (w && h))
    {
        getchar();
        cnt = 0;
        for(int i = 0; i < h; i++)//i是行 x
        {
            for(int j = 0; j < w; j++)//j是列 y
            {
                scanf("%c", &c[i][j]);
                if(c[i][j]=='@')
                {
                    sx = i, sy = j;
                }
            }
            getchar();
        }
//        for(int i = 0; i < h; i++)
//        {
//            for(int j = 0; j < w; j++)
//            {
//               cout << c[i][j];
//            }
//           cout << endl;
//        }
        dfs(sx, sy);
        printf("%d\n", cnt);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章