A - 廣搜 基礎

                     
A - 廣搜 基礎
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

//@author:  yzj   Date:2015/07/26
//sourse :  http://acm.hust.edu.cn/vjudge/contest/view.action?cid=82603#problem/A
//meaning:  農夫追牛,農夫每次可以走2*x, x-1 或 x+1三種方式,求最小時間
#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;
const int  MAXN  = 100000+5;
int n, k;
bool vis[MAXN];
int step[MAXN];
queue<int> que;

int bfs(int pos)
{
    que.push(pos);
    vis[pos] = true;
    step[pos] = 0;
    while(!que.empty())
    {
        int head, next;
        head = que.front();
        que.pop();
        for(int i = 0; i < 3; i++)//枚舉三種方法
        {
            if(i == 0)
            {
                next = head * 2;
            }
            else if(i == 1)
            {
                next = head + 1;
            }
            else
            {
                next = head - 1;
            }
            //超出界限, 跳過
            if(next < 0 || next > MAXN || vis[next]) continue;
            else
            {
                que.push(next);
                step[next] = step[head] + 1;
                vis[next] = true;
            }
            //廣搜的特性,返回的第一個一定是最短的路徑
            if(next == k) return step[next];
        }
    }
}

int main()
{
    //freopen("f:/yzj/cppCode/input.txt", "r", stdin);
    scanf("%d %d", &n, &k);
    if(n >= k) printf("%d\n", n-k);
    else printf("%d\n", bfs(n));
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章