hdu 1342

Problem Description
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k. 
 

Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case. 
 

Sample Input
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
 

Sample Output
1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34
代碼一:
時間:0ms,記錄過
#include<cstring>
#include<iostream>
#include<cstdio>
#include<cmath>

int a[15];//存輸出
int b[7];
int visit[15];
int k;
using namespace std;
void dfs(int num)//當前個數,也是下標數
{
    int i;
    if(num > 6)
    {
        for(i = 1; i <= 5; i++)
        {
            cout << b[i] << " ";
        }
        cout << b[6] << endl;
    }
    else
    {
    for (i = 1; i<= k; i++)
    {
        if (!visit[i] && a[i] > b[num-1])
        {
            b[num] = a[i];
            visit[i] = 1;
            dfs(num+1);
            visit[i] = 0;
        }
    }
    }
}

int main()
{
   int i,flag = 0;

   while (scanf("%d",&k) && k)
   {
       if(flag)
       {
           cout << endl;
       }
       memset(visit,0,sizeof(visit));
       for (i = 1; i <= k; i++)
       {
           scanf("%d",&a[i]);
       }
       b[0] = -100;
       dfs(1);
       flag = 1;

   }
   return 0;
}
代碼二:
時間:15ms,沒記錄

#include<cstring>
#include<iostream>
#include<cstdio>
#include<cmath>

int a[15];//存輸出
int b[7];
int visit[15];
int k;
using namespace std;
void dfs(int num, int cur)//當前個數,也是下標數
{
    int i;
    if(num > 6)
    {
        for(i = 1; i <= 5; i++)
        {
            cout << b[i] << " ";
        }
        cout << b[6] << endl;
    }
    else
    {
    for (i = cur; i<= k; i++)
    {
            b[num] = a[i];
            //visit[i] = 1;
            dfs(num+1,i+1);
            //visit[i] = 0;
    }
    }
}

int main()
{
   int i,flag = 0;

   while (scanf("%d",&k) && k)
   {
       if(flag)
       {
           cout << endl;
       }
       memset(visit,0,sizeof(visit));
       for (i = 1; i <= k; i++)
       {
           scanf("%d",&a[i]);
       }
       b[0] = -100;
       dfs(1,1);
       flag = 1;

   }
   return 0;
}

最後注意一下輸出格式:最後一個例子不輸出空行。 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章