PAT甲级 1004.Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意:
输入: 第一行有n和m。n代表一共有多少个结点,m代表一共有多少个非叶结点。接下来一共m行,格式为:

ID K ID[1] ID[2] … ID[K]

ID表示非叶结点的编号,K代表这个非叶结点一共有多少个孩子,接下来的ID[1…k]为这k个孩子的编号。

输出: 输出每一层没有孩子结点的结点个数。

思路:利用一个结构体记录每一个结点的父结点,所在层数,有无孩子。在输入的过程中会记录每一个孩子的父亲结点以及这个结点是否有孩子。层数可以在遍历的时候记录(已经知道根结点是第一层)。
参考文章


#include<iostream>
using namespace std;
struct node {
	int level=0;
	int father=0;
	bool nochild=1;
};
node a[105];
int l[105];
int main() {
	int n,m,k,c,id,maxlevel=1;
	scanf("%d %d",&n,&m);
	for(int i=1; i<=m; i++) {
		scanf("%d %d",&id,&k);
		a[id].nochild=0;
		for(int j=1; j<=k; j++) {
			scanf("%d",&c);
			a[c].father=id;
		}
	}
	a[1].level=1;
	//接下来遍历,记录每一个结点所在的层数以及最大层数(后面输出会用到最大层数)
	for(int i=1; i<=n; i++) {
		for(int j=1; j<=n; j++) {
			if(a[j].father==i) {
				a[j].level=a[i].level+1;
				if(a[j].level>maxlevel) maxlevel=a[j].level;
			}
		}
	}
	//遍历计算每层没有孩子结点的结点个数
	for(int i=1; i<=n; i++) {
		if(a[i].nochild==1) {
			l[a[i].level]++;
		}
	}
	for(int i=1; i<=maxlevel; i++) {
		if(i==1)
			printf("%d",l[i]);
		else printf(" %d",l[i]);
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章