PAT Advanced 1050 String Subtraction

1050 String Subtraction

Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1−S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

解題思路

hash思想, 將s2中的字符串對應asc碼錶示到vis中,訪問過表示1 循環一遍對應s2,如果s2中的字符標記爲訪問過的那麼就不輸出。

解題代碼

#include <iostream>
using namespace std;
int vis[10010];
int main(){
    string s1, s2;
    getline(cin, s1);
    getline(cin, s2);
    for (int i = 0; i < s2.size(); i++) vis[s2[i]] = 1;
    for (int i = 0; i < s1.size(); i++){
        if (vis[s1[i]]) continue;
        cout << s1[i];
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章