PAT Advanced 1013 Battle Over Cities

1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city 1 - city 2 and city 1 - city 3 Then if city 1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city 2 - city 3

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

      
    

Sample Output:

1
0
0

解題大意

在給定的圖中,現在假設如果其中的一個點不能訪問,當此點不能訪問的時候,需要讓其他的點是連通的,那麼設置不同的點不能訪問的時候,對應需要最少需要幾條邊使他們是連通的。

解題思路

1.dfs遍歷全圖求連通塊。 其實就是刪除不能訪問的點,之後找連通塊的數量的問題,假設現在有n個連通塊,那麼對應連接的邊就是 n - 1,此時只需要遍歷全圖找到連通塊的數量即可。
2. 使用並查集,路徑壓縮設置每個點對應的父節點,父節點的個數就是連通塊的數量,計數每個點合併的次數就是連接邊的次數

dfs解題代碼:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 1010;
int g[N][N];
bool vis[N];
int n, m, k;
void dfs(int cur) {
    vis[cur] = true;
    for(int i = 1; i <= n; i++)
        if(!vis[i] && g[cur][i] == 1) dfs(i);
}
int main() {
    int a, b;
    scanf("%d%d%d", &n, &m, &k);
    while (m --){
        scanf("%d%d", &a, &b);
        g[a][b] = g[b][a] = 1;
    }
    while(k --){
        int ocp;
        memset(vis, false, sizeof vis);
        scanf("%d", &ocp);
        int cnt = 0;
        vis[ocp] = true;
        for(int i = 1; i <= n; i++) {
            if(!vis[i]) {
                dfs(i);
                cnt++;
            }
        }
        printf("%d\n", cnt - 1);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章