PAT Advanced 1002 A+B for Polynomials

1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

      
    

Sample Output:

3 2 1.5 1 2.9 0 3.2

解題思路

模擬多項式相加的過程, 指數相同的係數相加。 使用hash的思想, 下標指數對應係數相加。

解題代碼

#include <cstdio>
using namespace std;
const int N = 1010;
double exp[N], b;
int n, a, cnt;
int main(){
    for(int i = 0; i < 2; i++){
        scanf("%d", &n);
         while (n --){
            scanf("%d %lf", &a, &b);
            exp[a] += b;
        }
    }
    for (int i = 0 ; i < N; i++){
         if ( exp[i] != 0) cnt ++;
    }
    printf("%d", cnt);
    for (int i = N; i >= 0; i--){
        if (exp[i] != 0)
            printf(" %d %.1f", i, exp[i]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章