POJ1258 Agri-Net 最小生成樹Prim

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

題意:給出若干城市及在每兩個城市中鋪設光纖的費用,要將所有城市通信,求最低費用。

最小生成樹問題:

#include<iostream>
#include<cstring>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=100; 
int N;
int cost[maxn][maxn],mincost[maxn]; 
bool used[maxn];
int prim(int src)
{
	int res=0;
	mem(used,false);
	for(int i=0;i<N;i++)
		mincost[i]=cost[src][i]; 
	mincost[src]=0;
	used[src]=true;
	for(int i=0;i<N-1;i++)//選擇其餘N-1個頂點 
	{
		int min=INF,k=0;
		for(int j=0;j<N;j++)//求出下一個結點k 
		 	if(!used[j]&&mincost[j]<min)
		 	{
		 		min=mincost[j],k=j;
			}
		if(min==INF) return -1;//非連通圖 
		used[k]=true;
		res+=min;
		for(int j=0;j<N;j++)
			if(mincost[j]>cost[k][j])//重新選擇最小邊 
				mincost[j]=cost[k][j];
	}
	return res;
	
}
int main()
{
	while(cin>>N)
	{
		for(int i=0;i<N;i++)
			for(int j=0;j<N;j++)
				scanf("%d",&cost[i][j]);
		cout<<prime(0)<<endl;	
	} 
	
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章