poj2406解题报告

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 33547   Accepted: 13935

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
源代码:
#include<iostream>
#include<cstring>
using namespace std;
int next[1000010];
char ch[1000010];
int len;
void getnext()
{
    int i,j;
i=0;
j=-1;
next[0]=-1;
while (i!=len)
{
   if (j==-1 || ch[i]==ch[j])
next[++i]=++j;
else 
j=next[j];
}
}
int main()
{
    int length;
while (scanf("%s",ch) && ch[0]!='.')
{
   len=strlen(ch);
getnext();
length=len-next[len];
if (len!=length && len%length==0)
cout<<len/length<<endl;
else 
cout<<"1"<<endl;
}
return 0;
}
本题题意:给出一串字符串,算出其中最小循环字符串的循环个数。就是说abcdabcd中有2个abcd,所以输出2,aaaaaa,最小循环是a,所以输出为6,本题运用了kmp算法,求出它的next数组,根据其中数字的显示,就能求出你所要的最小循环,呵呵,求next数组还是参考了一下网上大神的方法,我们老师上课教的方法似乎要用2个循环所以感觉没有这么简单易懂,ac之后的速度虽然不算快,但是还是一个最简单最容易想到的方法。
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章