HDU - 4883(蠻有趣的題)

TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
InputThe first line contains a positive integer T(T<=100), standing for T test cases in all. 

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time. 

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough. 
OutputFor each test case, output the minimum number of chair that TIANKENG needs to prepare. Sample Input
2
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00
Sample Output
11

6

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define maxn 2000
int t,n,a[maxn];
int main()
{
    scanf("%d", &t);
    while(t--)
    {
        memset(a, 0, sizeof(a));
        scanf("%d", &n);
        int num,hour1,minute1,hour2,minute2;
        for(int i=0; i<=n-1; i++)
        {
            scanf("%d%d:%d%d:%d",&num,&hour1,&minute1,&hour2,&minute2);
            int num1=hour1*60+minute1,num2=hour2*60+minute2;
            for(int j=num1; j<=num2-1; j++)
            {
                a[j]+=num;
            }
        }
        int ans = -1;
        for(int i=0; i<=maxn-1; i++)
        {
            ans = max(ans,a[i]);
        }
        printf("%d\n", ans);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章