【簡單題】CCPC Huatuo's Medicine L

Huatuo's Medicine

Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%lld & %llu

Description

Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these bottles together.

However, there was a critical problem. When Huatuo arrived the patient's home, he took the chain out of his bag, and he could not recognize which bottle contains which type of medicine, 
but he remembers the order of the bottles on the chain.

Huatuo has his own solution to resolve this problem. When he need to bring  types of medicines, E.g. A and B, he will put A into one bottle and put B into two bottles. 
Then he will chain the bottles in the order of -B-A-B-. In this way, when he arrived the patient's home, he knew that the bottle in the middle is medicine A and the bottle on 
two sides are medicine B.

Now you need to help Huatuo to work out what's the minimal number of bottles needed if he want to bring  types of medicine.

Input

The first line of the input gives the number of test cases, ().  lines follow. Each line consist of one integer (), 
the number of types of the medicine.

Output

For each test case, output one line containing Case #x: y, where  is the test case number (starting from ) and  is the minimal number of bottles Huatuo needed.

Sample Input


2

Sample Output

Case #1: 3


題意:

幫華佗找藥,藥的順序按題放。

解題思路:

就是找第n個奇數。

AC代碼:

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int main()
{
    int T;
    int xp=1;
    scanf("%d",&T);
    while(T--){
        int N;
        scanf("%d",&N);
        printf("Case #%d: %d\n",xp++,2*(N-1)+1);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章