【簡單題】HDOJ The MAX 2803



The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2038    Accepted Submission(s): 880


Problem Description
Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
 

Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output the biggest value of F you can find on a line.
 

Sample Input
2 1 2 0
 

Sample Output
4017
 

Source
 



水題~


AC代碼:

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

typedef long long LL;

int main()
{
    int n;
    while(scanf("%d",&n),n){
        LL v,MAXN=-99999999;
        LL res=0;
        for(int i=0;i<n;i++){
            scanf("%lld",&v);
            MAXN=max(MAXN,v);
            res+=v;
        }
        res-=MAXN;
        MAXN*=(2009-n+1);
        printf("%lld\n",res+MAXN);
    }
    return 0;
}


The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2038    Accepted Submission(s): 880


Problem Description
Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
 

Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output the biggest value of F you can find on a line.
 

Sample Input
2 1 2 0
 

Sample Output
4017
 

Source
 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章