POJ 2528 - Mayor's posters(模拟)

Mayor’s posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 60890 Accepted: 17606
Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.
Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

这里写图片描述

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output

4

题意:
给出n个海报粘到墙上,问最后能看到多少张海报(部分看到也算)。

解题思路:
线段树区间更新。
用模拟也可过,因为是后来的覆盖之前的,那么对于同一区域,后来的必然能看见。
那么就逆序遍历,如果之前没有覆盖,那么就把这一区域标记成海报右端的位置。
这样下次如果看到此区域,那么直接跳转到海报的最右端,从最右端开始,看能否进行覆盖。
对于每一个海报,只要有覆盖的操作,那么必然有这一部分能被看见。

AC代码:

#include<stdio.h>
#include<string.h>
int l[10005];
int r[10005];
int a[10000005];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        for(int i = 1;i <= n;i++)   scanf("%d%d",&l[i],&r[i]);
        int ans = 0;
        for(int i = n;i >= 1;i--)
        {
            int flag = 0;
            for(int j = l[i];j <= r[i];j++)
            {
                if(!a[j])   a[j] = r[i],flag = 1;
                else        j = a[j];
            }
            ans += flag;
        }
        printf("%d\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章