ZOJ 2855:Google Map

Time Limit: 2 Seconds      Memory Limit: 65536 KB

GoogleMap is a useful tool and most of you should be familiar with it. As the best hacker in the world, Jack is planning to retrieve all the data on the GoogleMap server. But he soon gives up because the total amount of data exceeds 1000T bytes! But he has learnt the way in which Google stores their data on the server, and he turns to download only the parts that he's interested in. Here is the representation of the data that Jack has found:

First of all, you should know the basic background knowledge of GIS (Geography Information System). In GoogleMap, the whole world is represented in a whole flat image transformed from the surface of the earth by Mercator projection. The Mercator projection is a map projection which is widely used for navigation. The following equations place the x-axis of the projection on the equator (from West to East) and the y-axis at longitude 0 (from South to North)

  • x = longitude * pi / 180;
  • y = ln(tan(pi / 4 + (latitude * pi / 180) / 2))

Here, the latitude is between [-85, 85] (negative for South) and the longitude is between [-180, 180] (negative for West) The left of the map image is W180 and the right is E180. The top of the map image is N85 and the bottom is S85. The maps have different levels. In the first level, the whole image consists of only one tile with tag name "t". For each tile in one level, it will be clipped into 4 equally sized parts and magnified by 2 in the next level.

 

And the new tag name for the tiles in the next level will be the tag of their parent tile followed by the identifier of the clip area in the parent tile. (that is, q for left-top, r for right-top, t for left-bottom, s for right-bottom) For example:

 

So there will be 4L tiles in level L (Assume the first level is labeled as level 0). More interestingly, the filename of the tile on the server is just the tag name. Although Jack is very genius, he doesn't know any programming language, so he turns to you for writing a tool to generate the tags for him.

Input

The input contains multiple test cases!

In each case, there will be three numbers. The first two are the coordinates that indicate the longitude and latitude of the interested location, and the third is the level number required by Jack.

The longitude is between [-180, 180] (negative for West) and the latitude is between [-85, 85] (negative for South)

Output

Output the tag for the tile in the specified level that contains the location in a single line.

You can assume that the location will not be at the boundary of any tiles.

Sample Input

80 33 2
-80 -33 4
72.12 46.68 10

Sample Output

trt
ttrqt
trtrstqsrqs

Notes

You can use the 'log(double)' function to calculate the natural logarithm, and 'tan(double)' to calculate the tangent value. Both of these functions are included in the header '<math.h>' for C or '<cmath>' for C++.

題解:注意不要抄錯公式......題意是將地圖分成四個象限,使用題目給的公式換算經緯度。如果在第一個象限字符串加 r ,依次類推。用到二分法判斷下一個level座標落在哪一個象限。

代碼:

#include<iostream>
#include<stdio.h>
#include<math.h>
#define pi acos(-1)
using namespace std;
int main()
{
    double x,y;
    int level;

    while(cin>>x>>y>>level)
    {
        string str="t";
        double top=log(tan(pi/4+(85*pi/180)/2));
        double down=log(tan(pi/4+(-85*pi/180)/2));
        double left=-180*pi/180;
        double right=180*pi/180;

        x=x*pi/180;
        y=log(tan(pi/4+(y*pi/180)/2));
        while(level--)
        {
           double mid_x=(left+right)/2;
           double mid_y=(top+down)/2;
           if(x<mid_x&&y<mid_y)
           {
               top=mid_y;
               right=mid_x;
               str+="t";
           }
           else if(x>mid_x&&y<mid_y)
           {
               top=mid_y;
               left=mid_x;
               str+="s";
           }
           else if(x<mid_x&&y>mid_y)
           {
               down=mid_y;
               right=mid_x;
               str+="q";
           }
           else
           {
               down=mid_y;
               left=mid_x;
               str+="r";
           }
        }
        cout<<str<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章