PAT 1038 Recover the Smallest Number(30 分)(頭文件#include)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

題解:第一個想法是用字典序來做,但是可以找出反例:32和321,組成的最小序列應該是32132,但是按照字典序則會排成 32321。在書上看到的辦法,記錄一下#include<string>頭文件中的函數使用。

代碼:

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
const int maxn=10005;
string str[maxn];
bool cmp(string a,string b)
{
    return a+b<b+a;
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>str[i];
    sort(str,str+n,cmp);
    string ans;
    for(int i=0;i<n;i++)
        ans+=str[i];
    while(ans.size()!=0&&ans[0]=='0')
        ans.erase(ans.begin());
    if(ans.size()==0)
        cout<<"0"<<endl;
    else
        cout<<ans<<endl;
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章