2242 The Circumference of the Circle

Description

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don’t?

You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.

Input

The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14
4.44
6.28
31.42
62.83
632.24
3141592.65

Source

Ulm Local 1996


求三角形外接圓周長:

設三角形三邊長分別爲a,b,c ,半周長爲p ,面積爲s ;外接圓半徑爲r ,周長爲cir

p=(a+b+c)/2

海倫公式:s=(p(pa)(pb)(pc)

正弦定理:c/sinC=2r

又因爲:s=(absinC)/2

所以周長:
cir=2pir=pic/sin=(piabc)/(2s)

=(piabc)/(2(p(pa)(pb)(pc))


/*求三角形外接圓周長*/
#include<iostream>
#include<iomanip>
#include<math.h>

using namespace std;

#define PI 3.141592653589793

double length(double x1,double y1,double x2,double y2)
{
    return sqrt((x1 - x2)*(x1 - x2) + (y1 - y2)*(y1 - y2));
}

int main()
{
    double x1, y1, x2, y2, x3, y3;
    double cir = 0;
    while (cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3)
    {
        double a = length(x1, y1, x2, y2);
        double b = length(x1, y1, x3, y3);
        double c = length(x2, y2, x3, y3);
        double p = (a + b + c) / 2;
        double s = sqrt(p*(p - a)*(p - b)*(p - c));
        cir = PI*a*b*c / (2 * s);
        cout << fixed << setprecision(2) << cir << endl;
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章