POJ - 2229 Sumsets

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

這題沒啥說的,找規律,遞推下去就行了,最後找出來的規律是

i爲奇數時,dp[i]=dp[i-1]

i爲偶數時,dp[i]=dp[i-1]+dp[i/2]

My Code:

#include<iostream>
#define ll long long
using namespace std;
ll a[1000005];
int main()
{
	a[1]=1;
	a[2]=2;
	for(int i=3;i<=1000000;i++)
	{
		if(i%2==0) a[i]=a[i-2]+a[i/2];
		else a[i]=a[i-1];
		if(a[i]>1000000000)a[i]%=1000000000;
	}
	ll t;
	cin>>t;
	cout<<a[t]%1000000000<<endl;
 } 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章