Ancient Go(模擬+搜索)

Ancient Go

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)



Problem Description
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.
 

Input
The first line of the input gives the number of test cases, T(1T100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.
 

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.
 

Sample Input
2 .......xo ......... ......... ..x...... .xox....x .o.o...xo ..o...... .....xxxo ....xooo. ......ox. .......o. ...o..... ..o.o.... ...o..... ......... .......o. ...x..... ........o
 

Sample Output
Case #1: Can kill in one move!!! Case #2: Can not kill in one move!!!
Hint
In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component. In the second test case, there is no way to kill Su Lu's component.




題解:給你一個9x9的方陣,讓你判斷其中是不是至少存在一個O,他的周圍被X環繞或爲邊界,只有一個方向是'.'

     思路:
            首先用個二維矩陣,存圖,遍歷每一個O,遍歷到一個O就判斷它是否符合條件,符合直接跳出,否
            則遍歷到底……



代碼如下


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<string>
#include<math.h>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ll long long
#define For(i,a,b) for(int i=a;i<b;i++)
#define sf(a)  scanf("%d",&a)
#define sfs(a)  scanf("%s",a)
#define sff(a,b)  scanf("%d%d",&a,&b)
#define sfff(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define pf(a) printf("%d\n",a)
#define P()  printf("\n")
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
char w[120][120];
int v[120][120];
int d[4][2]= {0,1,1,0,0,-1,-1,0};
int check(int x,int y)                 // 判斷此時的座標是否符合範圍和其他條件
{
    if(x>=0&&x<9&&y>=0&&y<9)
    {
        if(w[x][y]!='x')
            return 1;
        else return 0;
    }
    else return 0;
}
int ans=0;
int find(int x,int y)                  // 查找此時O點有幾個出口
{
    v[x][y]=1;
    int s=ans;
    for(int i=0; i<4; i++)
    {

        int xx=x+d[i][0],yy=y+d[i][1];
        if(check(xx,yy)&&!v[xx][yy])
        {
            v[xx][yy]=1;
            if(w[xx][yy]=='.')
                s++;
            ans=max(ans,s);
            if(w[xx][yy]=='o')
            {
                s=max(s,find(xx,yy));
            }
        }
    }
    return s;
}
int main()
{
    int t,s=0;
    sf(t);
    while(t--)
    {
        s++;
        For(i,0,9)sfs(w[i]);
        int flag=0;
        for(int i=0; i<9; i++)
        {
            for(int j=0; j<9; j++)
            {
                if(w[i][j]=='o')        // 遍歷
                {
                    mem(v,0);
                    ans=0;
                    int d=find(i,j);
                    if(d==1)            // 找到跳出
                    {
                        flag=1;
                        break;
                    }
                }
            }
            if(flag)                    // 找到跳出
                break;
        }
        printf("Case #%d: ",s);
        if(flag)
            printf("Can kill in one move!!!\n");
        else
            printf("Can not kill in one move!!!\n");
    }
}









發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章