Hdu 1075(stl map||字典樹)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 28605 Accepted Submission(s): 9746


 

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

Output

In this problem, you have to output the translation of the history book.

 

Sample Input


 

START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END

 

Sample Output


 
hello, i'm from mars. i like earth!

Hint

Huge input, scanf is recommended.

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<map>
using namespace std;
map<string,string>mp;
string a,b;
char s[2000];
int main()
{
	cin>>a;
	while(cin>>a){
		if(a=="END")break;
		cin>>b;
		mp[b]=a;
	}
	cin>>a;
	getchar();
	while(1){
		gets(s);
		if(!strcmp(s,"END")) break;
		int len=strlen(s);
		a="";
		for(int i=0;i<len;i++){
			if(islower(s[i])){
				a+=s[i];
			}
			else{
				if(mp.find(a)!=mp.end())
				cout<<mp[a];
				else
				cout<<a;
				a="";
				cout<<s[i];
			}
		}	
		cout<<endl;
	}
	return 0;
}
#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#define maxn 30
using namespace std;
struct TrieNode
{
	char* s;
	bool isword;
	TrieNode* next[26];
};
TrieNode node;
TrieNode* build()
{
	TrieNode* node=new TrieNode;
	node->isword=false;
	memset(node->next,0,sizeof(node->next));
	return node;
}
void Insert(char *s,char *code)
{
	int len=strlen(s);
	TrieNode* node=root;
	for(int i=0;i<len;i++)
	{
		int x=s[i]-'a';
		if(node->next[x]==NULL)
		node->next[x]=build();
		node=node->next[x];
	}
	node->isword=true;
	node->s=new char[strlen(code)];
	strcpy(node->s,code);
}
char* docode(char* s)
{
	int len=strlen(s);
	TriedNode* node=root;
	for(int i=0;i<len;i++)
	{
		int x=s[i]-'a';
		if(node->next[x]==NULL)
		return s;
		node=node->next[x];
	}
	if(node->isword) return node->s;
	return s;
}
void del(TrieNode* node)
{
	for(int i=0;i<26;i++)
	{
		if(node->next[i]!=NULL)
		del(node->s[i]);
	}
	free(node);
}
int main()
{
	root=build();
	char s1[maxn],s2[maxn];
	while(scanf("%s",s1)!=EOF)
	{
		if(!strcmp(s1,"START")==0) continue;
		else if(!strcmp(s1,"END")==0) break;
		scanf("%s",s2);
		inset(s2,s1);
	}
	getchar();
	char word[maxn];
	while(get(line))
	{
		if(strcmp(line,"START")==0)  continue;
        else if(strcmp(line,"END")==0)    break;

        int cnt=0,len=strlen(line);
        for(int i=0;i<len;i++){
            if('a'<=line[i]&&line[i]<='z'){
                word[cnt++]=line[i];
                word[cnt]='\0';
            }
            else{
                if(cnt)    printf("%s",decode(word));
                printf("%c",line[i]);
                cnt=0;
            }
        }
        if(cnt) printf("%s",decode(word));
        printf("\n");
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章