HDU 3501 Calculation 2 (欧拉函数)

Calculation 2

                                                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                    Total Submission(s): 4636    Accepted Submission(s): 1926


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
3 4 0
 

Sample Output
0 2

题意:给你一个数n,求小于n且不和n互质的数的和

思路:对于gcd( n , i )=1,有gcd( n , n-i )=1,故 n 以内的与 n 互质的数的和为 φ(n)*n/2,除了1,2,其余的φ(n)均为偶数

欧拉函数的其他性质:

Euler函数表达通式:euler(x) = x(1 - 1 / p1)(1 - 1 / p2)(1 - 1 / p3)(1 - 1 / p4)…(1 - 1 / pn), 其中p1, p2……pn为x的所有质因数,x>=1。euler(1) = 1(看情况而定,一般为1)。
欧拉定理:对于互质的正整数a和n,有a^φ(n) ≡ 1 mod n。
欧拉函数是积性函数——若m, n互质,φ(mn) = φ(m)φ(n)。
若n是质数p的k次幂,φ(n) = p^k - p ^ (k - 1) = (p - 1)p ^ (k - 1),因为除了p的倍数外,其他数都跟n互质。
特殊性质:当n为奇数时,φ(2n) = φ(n)

上代码:

#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<cstdio>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3f
#define mod (ll)1000000007
//if gcd(n,i)==1,then gcd(n,n-i)==1,so 1 to m = euler(n)*n/2
//so the answer=n*(n-1)/2-euler(n)*n/2 use long long
ll euler(ll n)
{
	ll res=n;
	for(ll i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			res=res/i*(i-1);
			while(n%i==0)
				n/=i;
		}
	}
	if(n>1)
		return res=res/n*(n-1);
	return res;
}
int main()
{
	ll n;
	while(scanf("%lld",&n)&&n)
	{
		ll res=euler(n);
		printf("%lld\n",((n*(n-1)/2)-(res*n/2))%mod);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章