HDU1004(STL-map)

B - STL之<map>
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input

5 green red blue red red 3 pink orange pink 0
 

Sample Output

red pink
  題意:給出氣球的顏色,輸出顏色最大的氣球。
 分析:
 (1)輸入字符串,每種分別計數(strcmp),輸出最大對應的字符串。
<span style="font-size:18px;">#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int n,k[1000];
    char a[1000][100];
    while(cin>>n,n)
    {
        int i,j,t;
        for(i=0; i<n; i++)cin>>a[i];
        for(i=0; i<n; i++)
        {
            t=0;
            for(j=0; j<n; j++)
                if(strcmp(a[i],a[j])==0)
                    k[i]=t++;
        }
        t=0;
        for(i=0; i<n; i++)
            if(k[i]>k[t])
                t=i;
        cout<<a[t]<<endl;
    }
    return 0;
}</span>
 (2)使用STL——<map>
   map中有一一映射的關係,建立color和count之間的關係即map<string,int>ball;

     it->first是map中第一個元素,it->second是map中第二個元素
#include <iostream>
#include <cstdio>
#include <string>
#include <map>
using namespace std;
#define N 102
map<string,int>ball;///顏色和個數的映射
map<string,int>::iterator it;
int main()
{
	int n;
	string color;
	while(scanf("%d",&n),n)
    {
        ball.clear();///先清0
        for(int i=0;i<n;i++)
        {
            cin>>color;
            ball[color]++;
        }
        int max=-1;
        for(it=ball.begin();it!=ball.end();it++)///map
        {
            if(it->second>max){
                color=it->first;
                max=it->second;
            }
        }
        cout<<color<<endl;
    }
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章