hdu1250(高精度壓位)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6230    Accepted Submission(s): 2060


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
100
 

Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


#include <iostream>
#include <cstring>
#include <iomanip>
using namespace std;
const int MAXN = 10000, MAXM = 260;
int mat[MAXN][MAXM];

void init(){
    mat[1][0]=1; mat[2][0]=1; mat[3][0]=1; mat[4][0]=1;
    for(int i=5; i<MAXN; i++){
        for(int j=0; j<MAXM; j++)
            mat[i][j]=mat[i-1][j]+mat[i-2][j]+mat[i-3][j]+mat[i-4][j];
        for(int j=0; j<MAXM; j++){
            if(mat[i][j]>=100000000){
                mat[i][j+1]+=mat[i][j]/100000000;
                mat[i][j]%=100000000;
            }
        }
    }
}

void print(int n){
    int i=MAXM-1;
    while(mat[n][i]==0) i--;
    cout<<mat[n][i];
    while(i) cout<<setw(8)<<setfill('0')<<mat[n][--i];
    cout<<endl;
}

int main()
{
    init();
    int n;
    while(cin>>n) print(n);
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章