Big Number(1212)

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5

1521

秦九韶

#include <stdio.h> 
#include <string.h>  
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <vector>
#include <stack>
#include <deque>
#include <queue>
#include <set>
#include <list> 
#include <map> 
#include <string>
using namespace std; 
#define INF 2147483647

int main()
{
	int n,i,l,sum;
	char s[100000];	
	
	while(scanf("%s %d",s,&n)!=EOF)
	{
		l=strlen(s);
		sum=0;
		for(i=0;i<l;i++)
		{
			sum*=10;
			sum+=s[i]-'0';
			sum%=n;
		}
		cout <<sum <<endl;		
	}
		
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章