【HDU - 1325】Is It A Tree?


點擊打開鏈接



Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26113    Accepted Submission(s): 5966


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.

//代碼如下:

#include <stdio.h>
#include <string.h>

const int maxn = 1e6 + 10;

int par[maxn];
int visit[maxn];  //記錄點是否出現 
int num[maxn];   //記錄點的入度  如果大於2 就成環了  可以在紙上花一下  就肯定不行了  

void init()
{
	for (int i = 0; i <= maxn; i++)
		par[i] = i, num[i] = 0, visit[i] = 0;
}

int find(int x)
{
	return x == par[x] ? x : par[x] = find(par[x]);
}

void unite(int a, int b)
{
	int fa = find(a);
	int fb = find(b);
	if (fa != fb)
		par[fa] = fb;
}

int main()
{
	int n, m;
	int t = 1;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		if (n < 0 && m < 0)
			break;
		init();
		if (m == 0 && m == 0)
		{
			printf("Case %d is a tree.\n", t++);
			continue;
		}
		bool flag = true;
		while (n || m)
		{
			visit[n] = 1, visit[m] = 1;
			num[m]++;
			if (num[m] > 1)   //入度大於1 
				flag = false;
			if (find(n) == find(m)) //說明這兩個點已經在一棵樹上了  再加入的話就會出現成環或者重邊  判斷兩個點在不在一棵樹上一可以用這種方法
				flag = false; 
			unite(n, m);
			scanf("%d%d", &n, &m);
		}
		int ans = 0, sum = 0;    //ans記錄出現的點的個數  下面防止單獨的一個點   sum標記集合的個數 防止森林的出現  
		//下面開始特判 這個題坑點比較多 
		for (int i = 0; i <= maxn; i++)
		{
			if (par[i] == i && visit[i] == 1)
				sum++;
			if (visit[i] == 1)
				ans++;
		} 
		if (sum > 1)
			flag = false;
		if (sum == 1 && ans == 1)  //這個就是上面說的單獨的一個點
			flag = false;
		if (flag)
			printf("Case %d is a tree.\n", t++);
		else
			printf("Case %d is not a tree.\n", t++);
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章