hdu 1008 Elevator


Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 46694    Accepted Submission(s): 25735
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop. For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case. 
 
Sample Input
1 2 3 2 3 1 0
 

Sample Output
17 41

題目大意:就是說現在有個升降機,上升一層就要花6秒時間,到了目標樓層後會停留5秒時間,下降一層要花4秒時間,你一開始現在在0層,OJ提供你樓層信息,你計算出整個過程所花費的時間。
#include<stdio.h>
#include<string.h>
#define Max 105
int main()
{
	int floor[Max],N,i;
	int temp;
	memset(floor,0,sizeof(floor));
	while(scanf("%d",&N)&&N)
	{
		int time=0;
		for(i=1;i<=N;i++)
		{
			scanf("%d",&floor[i]);
			temp=floor[i]-floor[i-1];
			if(temp>0)
			{
				time+=temp*6+5;
				continue;
			}
			if(temp<0)
			{
				time+=-temp*4+5;
				continue;
			}
			if(temp==0)
			{
				time+=5;
				continue;
			}
		}
		printf("%d\n",time);
	}
	return 0;
}

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46694    Accepted Submission(s): 25735


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
1 2 3 2 3 1 0
 

Sample Output
17 41
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章