hdu_problem_2025_查找最大元素

/*
*
*Problem Description
*對於輸入的每個字符串,查找其中的最大字母,在該字母后面插入字符串“(max)”。
*
*
*Input
*輸入數據包括多個測試實例,每個實例由一行長度不超過100的字符串組成,字符串僅由大小寫字母構成。
*
*
*Output
*對於每個測試實例輸出一行字符串,輸出的結果是插入字符串“(max)”後的結果,如果存在多個最大的字母,就在每一個最大字母后面都插入"(max)"。
*
*
*Sample Input
*abcdefgfedcba
*xxxxx
*
*
*Sample Output
*abcdefg(max)fedcba
*x(max)x(max)x(max)x(max)x(max)
*
*
*Author
*lcy
*
*
*Source
*C語言程序設計練習(四)
*
*
*Recommend
*lcy
*
*/
#include<iostream>
#include<string>
using namespace std;
int main() {
 string s;
 char max;
 while (cin >> s) {
  max = s.at(0);
  for (int i = 0; i < s.size(); i++) {
   if (s.at(i) > max) max = s.at(i);
  }
  for (int i = 0; i < s.size(); i++) {
   if (s.at(i) == max) {
    s.insert(i + 1, "(max)");
    i += 5;
   }
  }
  cout << s << endl;
 }
 system("pause");
 return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章