hdu1069(第二天題E)

題目:
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

目標把每種石頭上面能放最高多少算出來,然後加到下一塊。
解:先把每種石頭弄出來,要進行從大到小排序(排序後纔可以做上面這個)
可以用sort函數排序

#include<iostream>
#include<algorithm>
struct k
{
	int x;
	int y;
	int z;
	int dp;
}pp[92];
bool tmp(k x,k y)
{
	if (x.x == y.x)
	{
		return x.y > y.y;
	}
	else
	{
		return x.x > y.x;
	}
}

void big(int *x, int *y)
{
	if (*y > *x)
	{
		int temp = *y;
		*y = *x;
		*x = temp;
	}
}
using namespace std;
int main()
{
	int x, y, z;
	int n;
	int num = 0;
	while (cin >> n)
	{
		num++;
		if (n == 0)
		{
			break;
		}
		memset(pp, 0, sizeof(pp));
		int k = 0;
		while (n--)
		{
			k++;
			cin >> x >> y >> z;
			if (x == y)
			{
				if (x == z)
				{
					pp[k].x = x;
					pp[k].y = x;
					pp[k].z = x;
				}
				else
				{
					pp[k].x = x;
					pp[k].y = y;
					pp[k].z = z;
					k++;
					pp[k].x = x;
					pp[k].y = z;
					pp[k].z = y;
				}
			}
			else
			{
				if (x == z)
				{
					pp[k].x = x;
					pp[k].y = y;
					pp[k].z = z;
					k++;
					pp[k].x = x;
					pp[k].y = z;
					pp[k].z = y;
				}
				else
				{
					pp[k].x = x;
					pp[k].y = y;
					pp[k].z = z;
					k++;
					pp[k].x = x;
					pp[k].y = z;
					pp[k].z = y;
					k++;
					pp[k].x = y;
					pp[k].y = z;
					pp[k].z = x;
				}
			}
		}
		for (int i = 1; i <= k; i++)
		{
			big(&pp[i].x, &pp[i].y);
		}
		sort(pp+1, pp + k+1, tmp);
		for (int i = 1; i <= k; i++)
		{
			pp[i].dp = pp[i].z;
			int q = pp[i].dp;
			for (int j = 1; j < i; j++)
			{
				if (pp[i].x < pp[j].x&&pp[i].y < pp[j].y/*|| pp[i].x == pp[j].x&&pp[i].y > pp[j].y|| pp[i].x > pp[j].x&&pp[i].y == pp[j].y*/)
				{
					pp[i].dp = max(pp[i].dp, pp[j].dp + q);
				}
			}
		}
		int q = 0;
		for (int i = 1; i <= k; i++)
		{
			if (q < pp[i].dp)
			{
				q = pp[i].dp;
			}
		}
		cout << "Case " << num << ": maximum height = " << q << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章