PAT A1081 題解


1081 Rational Sum (20 分)
Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24


題目大意:給定一個自然數n,然後讀入n個分數,求n個分數的和,如果是整數的話,直接輸出;如果是假分數,則按照帶分數形式輸出,真分數也直接輸出。


題目思路:設定數據結構fenshu,兩個成員up和down,設定規則,僅讓up有可能爲負,所以當down爲負數的話,up和down都設爲相反數。而當up=0時,設置down=1;找出最大公約數然後讓up和down同除。而分數加法運算f1+f2sum.up =f1.up * f2.down + f1.down * f2.up,sum.down=f1.down*f2.down.


#include<iostream>
#include<algorithm>
typedef long long ll;
using namespace std;
struct fenshu{
	ll up,down;
};
ll gcd(ll a,ll b){
	return b==0?a:gcd(b,a%b);
}
fenshu reduct(fenshu result){
//化簡
	if(result.down<0){
		result.up=-result.up;
		result.down=-result.down;
	} 
	if(result.up==0){
		result.down=1;
	}
	else{
		int yueshu=gcd(abs(result.up),abs(result.down));
		result.up/=yueshu;
		result.down/=yueshu;
	}
	return result;
}
fenshu add(fenshu f1,fenshu f2){
	fenshu result;
	result.up=f1.up*f2.down+f1.down*f2.up;
	result.down=f1.down*f2.down;
	return reduct(result);
}
void showresult(fenshu f){
	reduct(f); 
	if(f.down==1){
		printf("%lld",f.up);
	}
	else if(abs(f.up)>f.down){
		printf("%lld %lld/%lld",f.up/f.down,abs(f.up)%f.down,f.down);
	}
	else{
		printf("%lld/%lld",f.up,f.down);
	}
}
int main(){
	int n;
	cin>>n;
	fenshu sum,temp;
	sum.up=0;
	sum.down=1;
	for(int i=0;i<n;i++){
		scanf("%lld/%lld",&temp.up,&temp.down);
		sum=add(sum,temp);
	}
	showresult(sum);	
	return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章