POJ - 1562 Oil Deposits 【搜索】

Time Limit: 1000MS   Memory Limit: 10000K

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

AC代碼

// dfs 和 bfs 都一樣的思路
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
struct Node {
    int x,y;
    Node(int xx,int yy):x(xx),y(yy) {}
};
int main()
{
    int m,n;
    char a[101][101];
    bool book[101][101];
    while(cin >> m >> n && (m!=0 && n!=0)) {
        memset(book,false,sizeof book);
        for(int i=1;i<=m;i++)
            cin >> a[i]+1;
        int sum=0;  // 用來統計有幾塊油田
        int next[8][2] = {{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};
        for(int i=1;i<=m;i++) {
            for(int j=1;j<=n;j++) {
                if(a[i][j] == '@' && !book[i][j]) {
                    queue< Node> Oil;
                    sum++;
                    Oil.push(Node(i,j));
                    book[i][j] = true;
                    while(!Oil.empty()) {
                        int tx,ty;
                        Node t = Oil.front();
                        for(int i=0;i<8;i++) {
                            tx = t.x+next[i][0];
                            ty = t.y+next[i][1];
                            if(tx > m || tx < 1 || ty > n || ty < 1)
                                continue;
                            if(a[tx][ty] == '@' && !book[tx][ty]) {
                                Oil.push(Node(tx,ty));
                                book[tx][ty] = true;
                            }
                        }
                        Oil.pop();
                    }
                }
            }
        }
        cout << sum << endl;
    }
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章