Super Jumping! Jumping! Jumping!(動態規劃)

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now。
在這裏插入圖片描述
The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow: N value_1 value_2 …value_N It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

題目大意

現有一盤棋,從開頭跳到結尾,必須從一個棋子跳到另一個更大的棋子,切不可後退。一次跳躍可以從一個棋子跳到下一個棋子,也可以跨越許多棋子,甚至可以直接從起點到終點,但是每一個棋子都有一定分數,要你求能獲得的最大分數。

思路

使用動態規劃。
定義一個動態數組dp[]
使用兩重for循環,將兩個位置上的棋子的價值進行比較。
如果後面的棋子價值大(我們看成a[i]>a[j])。則將dp[i]=max(dp[i],dp[j]+a[i]);
反之後面的棋子價值小(我們看成a[i]<a[j])。則將dp[i]=max(dp[i],a[i]);
這樣經過兩重循環後,我們可以得到,走到第i個旗子位置上最高得分dp[i];
將dp數組排序,得到最大值即可。

代碼

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
    int n,sum,i,j;
    int a[1005],dp[1005];			//dp數組用來實現動態規劃
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            dp[i]=0;
        }
        dp[0]=a[0];
        for(i=1;i<n;i++)
        {
            for(j=0;j<i;j++)
            {
                if(a[i]>a[j])			//如果後面的棋子大
                    dp[i]=max(dp[i],dp[j]+a[i]);
                else						//如果後面的棋子小
                    dp[i]=max(a[i],dp[i]);
            }
        }
        sort(dp,dp+n);				//進行排序
        printf("%d\n",dp[n-1]);

    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章