pdsu:1059 Dividing(多重揹包)

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0’’. The maximum total number of marbles will be 20000. The last line of the input file will be "0 0 0 0 0 0’’; do not process this line.

Output

For each colletcion, output "Collection #k:’’, where k is the number of the test case, and then either "Can be divided.’’ or "Can’t be divided.’’. Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

題目概述

瑪莎和比爾有一堆彈珠。他們想要把這些收藏品分成兩份,
有六種彈珠,每個彈珠的價值是一個介於1和6之間的自然數,
現在,要輸入6個整數,表示每個價值的彈珠的個數,
題目要求你寫一個程序來檢查玻璃球是否有一個公平的分割。(使他們兩個分得得的彈珠價值相等)

思路

使用多重揹包,但該道題,我們首先需要使用二進制轉化的方法,將每個玻璃球的數量,轉化成價值來存儲。

代碼

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>

using namespace std;
int v[10],f[1200005],w[200005];
int main()
{
    int i,j,sum;
    int t=0;
    while(1)
    {
        t++;
        sum=0;
        int k=0;
        for(i=1;i<=6;i++)
        {
            scanf("%d",&v[i]);
            sum=sum+v[i]*i;     //求玻璃球的總價值
            //將個數轉化爲價值
            for(j=1;j<=v[i];j<<=1)
            {
                w[k++]=j*i;
                v[i]-=j;
            }
            if(v[i]>0)
            {
                w[k++]=v[i]*i;
            }
            //轉化完成
        }
        if(sum==0)
            break;
        printf("Collection #%d:\n",t);
        if(sum%2!=0)      //不是偶數一定不可以平分
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        memset(f,0,sizeof(f));
        for(i=0;i<k;i++)//01揹包一樣
        {
            for(j=sum/2;j>=w[i];j--)
            {
                f[j]=max(f[j],f[j-w[i]]+w[i]);
            }
        }
        if(f[sum/2]==sum/2)
            printf("Can be divided.\n\n");
        else
            printf("Can't be divided.\n\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章