POJ-1050 To the Max(最大子矩陣和)

To the Max

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 54953 Accepted: 29070
Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input
 4
 0  -2  -7  0 
 9   2  -6  2
-4   1  -4  1 
-1   8   0 -2
Sample Output
15
Source

Greater New York 2001

鏈接:

http://poj.org/problem?id=1050

題意:

最大子矩陣問題

給定一個n*n(0<n<=100)的矩陣,請找到此矩陣的一個子矩陣,並且此子矩陣的各個元素的和最大,輸出這個最大的值。

分析:

首先先了解下求最大子段和問題

問題描述:
給定n個整數(可能爲負整數)組成的序列a1,a2,a3……an。求該序列如同的子段和的最大值

#include <stdio.h>

//N是數組長度,num是待計算的數組,放在全局區是因爲可以開很大的數組
int N, num[134217728];

int main()
{
    //輸入數據
    scanf("%d", &N);
    for(int i = 1; i <= N; i++)
        scanf("%d", &num[i]);
    
    num[0] = 0;
    int ans = num[1];
    for(int i = 1; i <= N; i++) {
        if(num[i - 1] > 0) num[i] += num[i - 1];
        else num[i] += 0;
        if(num[i] > ans) ans = num[i];
    }

    printf("%d\n", ans);

    return 0;
}

這個題和上面的解體思路類似,我們可以把二維變成一維,把下面每一行加到上一行中對應列中。

例如:

a11 a12 a13
a21 a22 a23
a31 a32 a33

先求第一行最大子段和,再求第一行跟第二行合起來的最大子段和,如a21+a11, a22+a12, a23+a13 的最大子段和,再求第一到第三合起來的最大子段和,如a11+a21+a31, a12+a22+a32, a13+a23+a33的最大子段和……以此類推,直到求出整個矩陣的合起來的最大子段和,求出他們之中最大的那個和就是解.

代碼:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 105;
int a[maxn][maxn];
int main()
{
    int n;
    scanf("%d", &n);
    int maxx = -1*0x3f3f3f3f;
    for(int i = 0; i < n; i++) {
        int temp = 0;
        for(int j = 0; j < n; j++) {
            scanf("%d", &a[i][j]);
            if(temp > 0)
                temp += a[i][j];
            else
                temp = a[i][j];
            if(temp > maxx)
                maxx = temp;
        }
    }
    for(int i = 0; i < n-1; i++) {
        for(int j = i+1; j < n; j++) {
            int temp = 0;
            for(int k = 0; k < n; k++) {
                a[i][k] += a[j][k];
                if(temp > 0)
                    temp += a[i][k];
                else
                    temp = a[i][k];
                if(temp > maxx)
                    maxx = temp;
            }
        }
    }
    printf("%d\n", maxx);


    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章