PTA甲級——1001A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    int a,b,sum;
    scanf("%d%d",&a,&b);
    sum=a+b;
    if(sum<0)
    {
        printf("%c",'-');
        sum*=-1;
    }
    if(sum>=1000000)printf("%d,%03d,%03d",sum/1000000,sum%1000000/1000,sum%1000);
    else if(sum>=1000)printf("%d,%03d",sum/1000,sum%1000);
    else printf("%d",sum);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章