HDU-2594 Simpsons’ Hidden Talents(KMP)

HDU-2594 Simpsons’ Hidden Talents

題面

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

題意

​ 多組輸入,給出兩個字符串,要你找出第一個字符串的前綴和第二個字符串的後綴的最長相同部分。

思路

​ 將兩個字符串合併,並在合併兩個字符串時,在它們之間加上值爲-1的char類型變量。因爲輸入的ascⅡ碼不會小於0,所以用-1隔開是墜吼的。然後用kmp預處理的方法取得這個合併字符串的next數組,若最後一位是0則不存在,反之存在。

AC代碼

#include <cstdio>
#include <cstring>
using namespace std;

const int MAXN = 1e5+5;
void kmp_pre(char x[], int next[]) {
    int i, j;
    j = next[0] = -1;
    i = 0;
    int m = strlen(x);
    while (i < m) {
        while (-1 != j && x[i] != x[j]) j = next[j];
        next[++i] = ++j;
    }
}
int next[MAXN];
char s1[MAXN];
int main() {
    // freopen("RAW/in", "r", stdin);
    // freopen("RAW/out", "w", stdout);
    while (scanf("%s", s1) != EOF) {
        memset(next, 0, sizeof(next));
        int m = strlen(s1);
        s1[m] = -1;
        printf("%d\n", s1[m]);
        scanf("%s", s1+m+1);
        m = strlen(s1);
        kmp_pre(s1, next);
        if(next[m] != 0) {
            for(int i = 0; i < next[m]; i++) {
                printf("%c", s1[i]);
            }
            printf(" %d\n", next[m]);
        } else {
            printf("0\n");
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章