HDU-2594 Simpsons’ Hidden Talents(KMP)

HDU-2594 Simpsons’ Hidden Talents

题面

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题意

​ 多组输入,给出两个字符串,要你找出第一个字符串的前缀和第二个字符串的后缀的最长相同部分。

思路

​ 将两个字符串合并,并在合并两个字符串时,在它们之间加上值为-1的char类型变量。因为输入的ascⅡ码不会小于0,所以用-1隔开是坠吼的。然后用kmp预处理的方法取得这个合并字符串的next数组,若最后一位是0则不存在,反之存在。

AC代码

#include <cstdio>
#include <cstring>
using namespace std;

const int MAXN = 1e5+5;
void kmp_pre(char x[], int next[]) {
    int i, j;
    j = next[0] = -1;
    i = 0;
    int m = strlen(x);
    while (i < m) {
        while (-1 != j && x[i] != x[j]) j = next[j];
        next[++i] = ++j;
    }
}
int next[MAXN];
char s1[MAXN];
int main() {
    // freopen("RAW/in", "r", stdin);
    // freopen("RAW/out", "w", stdout);
    while (scanf("%s", s1) != EOF) {
        memset(next, 0, sizeof(next));
        int m = strlen(s1);
        s1[m] = -1;
        printf("%d\n", s1[m]);
        scanf("%s", s1+m+1);
        m = strlen(s1);
        kmp_pre(s1, next);
        if(next[m] != 0) {
            for(int i = 0; i < next[m]; i++) {
                printf("%c", s1[i]);
            }
            printf(" %d\n", next[m]);
        } else {
            printf("0\n");
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章