PTA甲級——1008 Elevator (20 分)

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

code:

/*1008
*/
#include<bits/stdc++.h>
using namespace std;
int main(){
    int n,time=0,floor=0,temp_floor;
    cin>>n;
    time+=n*5;
    for(int i=0;i<n;i++){
        cin>>temp_floor;
        if((temp_floor-floor)>=0)time+=(temp_floor-floor)*6;
        else time+=(floor-temp_floor)*4;
        floor=temp_floor;
    }
    cout<<time;
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章