Bridging signals

D - Bridging signals
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too 
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 
 
Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side. 
Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4

設置k爲第 i 位結尾的LIS的長度。
設置s[ k ]表示滿足所有滿足的k裏面最小的a[ i ](1 <= i <= n),因爲我們要最優的LIS,等長度下,肯定前一位儘量小。
實現過程:遍歷序列,對序列當前遍歷的元素a[i],在數組s裏面查找第一個比它大的元素的位置,若能找到,用a[i] 替換s數組該位置的元素,若找不到(該元素比序列裏面所有元素都要大),將該元素加在數組s的最後。遍歷到最後,數組s裏面元素的個數就是LIS的長度(但不是LIS的序列)。用STL lower_bound來實現二分查找。
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
	int l,w;
};
node a[5010];
int f[5010];
int cmp(node n1,node n2){
	return n1.l!=n2.l?n1.l>n2.l:n1.w>n2.w;
}

int main(){
	int t,n;
	memset(a,-1,sizeof(a));
	memset(f,0,sizeof(f));
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i=0; i<n; i++){
			scanf("%d%d",&a[i].l,&a[i].w);
		}
		sort(a,a+n,cmp);
		int len = 1;
		f[len] = a[0].w;
		for(int i=1; i<n; i++){
			if(a[i].w>f[len]){
				f[++len] = a[i].w;
			}
			else{
				int tmp = lower_bound(f,f+len,a[i].w)-f;
				f[tmp] = a[i].w;
			}
		}
		printf("%d\n",len);
		
	}
	
	
	return 0;
}

發佈了93 篇原創文章 · 獲贊 4 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章