Hexadecimal View HDU 4054 簡短代碼 詳解



Hexadecimal View

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1837    Accepted Submission(s): 753


Problem Description
Hexadecimal is very important and useful for computer programmers. You are requested to provide a hexadecimal view for given data. The hexadecimal view is made up of one or more rows. Every row except the last one represents 16 characters. Each row consists of three columns separated by a space:

* addr: the 4-digit hexadecimal beginning address of this row.
* dump: the hexadecimal representation of this row, separating every two characters by a whitespace. If there are less than 16 characters in the last row, pad it with spaces.
* text: the ASCII translation of this row, with uppercase characters converted to lowercase and lowercase characters converted to uppercase.
Use lowercase for the letter digits. See sample for more details.
 

Input
There are multiple test cases. Each line is a test case. The line is made up of no less than 1 and no more than 4096 printable characters including spaces.
 

Output
For each test case, output its hexadecimal view. Do not output any extra spaces after the last character of text.
 

Sample Input
Hex Dump #include <cstdio> printf("Hello, World!\n"); main = do getLine >>= print . sum . map read . words
 

Sample Output
0000: 4865 7820 4475 6d70 hEX dUMP 0000: 2369 6e63 6c75 6465 203c 6373 7464 696f #INCLUDE <CSTDIO 0010: 3e > 0000: 7072 696e 7466 2822 4865 6c6c 6f2c 2057 PRINTF("hELLO, w 0010: 6f72 6c64 215c 6e22 293b ORLD!\N"); 0000: 6d61 696e 203d 2064 6f20 6765 744c 696e MAIN = DO GETlIN 0010: 6520 3e3e 3d20 7072 696e 7420 2e20 7375 E >>= PRINT . SU 0020: 6d20 2e20 6d61 7020 7265 6164 202e 2077 M . MAP READ . W 0030: 6f72 6473 ORDS
 

Author
WU, Zejun
 

Source
 

Recommend



lcy   |   We have carefully selected several similar problems for you:  4055 4057 4056 4059 4053 


注意:行號最後一位是恆等於0,且爲16進制,如     02a0。。。。

這個題糾結了許久,一開始WA了n次,而且調了很久都沒弄出錯誤在哪,後來乾脆換了個簡單的思路:Ac代碼如下:
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>

using namespace std;

char input[4100];

int main()
{
    int i,j,len,k;

    while(gets(input) != NULL)
    {
        len = strlen(input);
        for(i = 0;i < len;i+=16)//最外層循環,每次使標記前進16個字符----因爲每輸出16個字符爲一個循環
        {
            printf("%04x:",i);//i永遠是16的整數倍,可以確保以十六進制輸出時最後一位爲0————舉個例子就想清了——%04X加0是要0補齊前面的位置
            for(j = i;j < i + 16;j++)//輸出字符
            {
                if(j % 2 == 0) printf(" ");//數字之間的空格
                if(j < len)printf("%02x",input[j]);
                else printf("  ");     //j < len,說明輸出還未滿16個字符就沒有字符了,那就用空格代替
            }
            printf(" ");//最後追加一個空格
            
            for(k = i;k < i + 16 && k < len;k++)//對字符的大小寫處理
            {
                if(isalpha(input[k]) == 2) printf("%c",input[k] - 'a' + 'A');
                else if(isalpha(input[k]) == 1) printf("%c",input[k] - 'A' + 'a');
                else printf("%c",input[k]);
            }
            printf("\n");
        }
    }
    return 0;
}
/////
/////

WA代碼如下(很複雜,註釋就不寫了,抽空再反過來看一下)


#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

char input[4100],temp[4100];
int line;


int main()
{
    int i,j,len,k,m;

    while(gets(input) != NULL)
    {
        len = strlen(input);

        for(i = 0;i < len;i++)
        {
            if(isalpha(input[i]) == 1) temp[i] = input[i] + 32;
            else if(isalpha(input[i]) == 2) temp[i] = input[i] - 32;
            else temp[i] = input[i];
        }

        printf("0000:");
        line = 0;
        k = 5;

        for(i = 0;i < len;i++)
        {
            if(i % 16 == 0 && i)
            {
                printf(" ");
                for(j = i - 16; j < i;j++)
                    printf("%c",temp[j]);
                line++;
                printf("\n%03x0:",line);
                k = 5;
            }

            if(i % 2 == 0) {printf(" ");k++;}
            printf("%02x",input[i]);k+=2;
        }

        if(len % 16 != 0)
        {
            printf(" ");k++;
            for(m = 0;m < 45 - k + 1;m++)
                printf(" ");
            for(j = len - len % 16;j < len;j++)
                printf("%c",temp[j]);
        }
        printf("\n");
        memset(input,'\0',sizeof(input));
        memset(temp,'\0',sizeof(temp));
    }
    return 0 ;
}


發佈了96 篇原創文章 · 獲贊 1 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章