POJ P2155 Matrix

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 18581   Accepted: 7001

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng


當年樓教主出的題目,當時在NOIP時代流行的一句話是雖然我不會這道題,但是我能AC它。這道題就是典型的這種題。此題乍看之下區間修改加詢問,可以用二維線段樹做,不過我不會建議你這麼試的,因爲實在是太煩了,而且這題還卡空間,你還不一定能過。仔細一看會發現它是單點詢問,而不是區間詢問,是樓教主出題出簡單了呢,還是另有隱情。答案是後者,這題用到了樹狀數組神奇的性質,本來樹狀數組是用來區間查詢,單點修改,這題剛好倒了一下,即用二維樹狀數組區間查詢的方法來修改區間,而用單點修改的方法來單點查詢,真的是神奇,我說不上爲什麼這麼做可以,但是卻可以AC這道題。


代碼:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<ctime>
#include<string>
#include<cstring>
#include<algorithm>
#include<fstream>
#include<queue>
#include<stack> 
#include<vector>
#include<cmath>
#include<iomanip>
#define rep(i,n) for(i=1;i<=n;i++)
#define MM(a,t) memset(a,t,sizeof(a))
#define lowbit(x) x&(-x)
#define fan(a) 1-a 
#define INF 1e9
typedef long long ll;
#define mod 1000000007
using namespace std;
int n,m;
int bita[1020][1020];
void update(int x,int y){
  int i,j;
  
  for(i=x;i>0;i-=lowbit(i))
    for(j=y;j>0;j-=lowbit(j))
      bita[i][j]=fan(bita[i][j]);
  
}
int query(int x,int y){
	int i,j,res=0;
	
	for(i=x;i<=n;i+=lowbit(i))
	  for(j=y;j<=n;j+=lowbit(j)){
          if(bita[i][j]) res=fan(res);
  	    }
   
   return res;
}
int main()
{
	int i,j,T;
	
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&n,&m);
		MM(bita,0);
		rep(i,m){
			char op[10];
			scanf("%s",op);
			if(op[0]=='C'){
				int x1,y1,x2,y2;
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				update(x1-1,y1-1); update(x2,y2);
				update(x1-1,y2); update(x2,y1-1);
			}
			else{
			  int x,y;
			  scanf("%d%d",&x,&y);
			  printf("%d\n",query(x,y));	
			}
		}
		if(T!=0) cout<<'\n';
	}
	
	return 0;
}





發佈了41 篇原創文章 · 獲贊 1 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章