POJ 25456 Aggressive cows 【二分最大化最小值】

Aggressive cowsTime Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.


题目描述:

         农夫约翰搭了一间牛棚,有N个牛舍。牛舍排在一条线上,第i号牛舍在xi的位置。但是他的M头牛对小屋不满意,因此经常相互攻击。约翰为了防止牛之间相互伤害,

因此决定把每头牛都放在离其他牛尽可能远的牛舍。也就是要最大化最近的两头牛之间的距离。


<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int a[100010];
int main()
{
    int n,m;
    while(~scanf("%d %d",&n, &m))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        int l=0,r=a[n-1];
        int ans=0,sum=0;
        while(l<=r){
            int mid=(l+r)>>1;
            int ant=a[0];
            ans=1;
            for(int i=1;i<n;i++){
                if(a[i]-ant>=mid){
                    ans++;
                    ant=a[i];
                }
            }
            if(ans>=m){
                sum=max(sum,mid);
                l=mid+1;
            }
            else r=mid-1;
        }
        printf("%d\n",sum);
    }
    return 0;
}
</span>



发布了106 篇原创文章 · 获赞 5 · 访问量 5万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章