2017 Multi-University Training Contest - Team 1 HDU 6033 Add More Zero【對數】

題目來戳呀

Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

1
64

Sample Output

Case #1: 0
Case #2: 19

題意:

用10^k表示出2^m-1,求k的最大整數值。

想法:

因爲1≤m≤1e5,所以2^m的最後一位只能爲2,4,8,6,因此2^m-1中的-1對它的結果不會造成影響。
問題轉化成10^k<=2^m-1,兩邊同時取對數(-1忽略不計),得k<=m*lg2。

#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int m,cnt;
    cnt=1;
    while(~scanf("%d",&m))
    {
        int ans=(int)m*log10(2.0);//注意對數的表達
        printf("Case #%d: %d\n",cnt++,ans);
    }
    return 0;
}

ps:題意理解很重要!!!

發佈了87 篇原創文章 · 獲贊 8 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章