HDU 6047 Maximum Sequence【貪心】

題目來戳呀

Problem Description

Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2n. Just like always, there are some restrictions on an+1…a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤j

Input

The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output

For each test case, print the answer on one line: max{∑2nn+1ai} modulo 109+7。

Sample Input

4
8 11 8 5
3 1 4 2

Sample Output

27

Hint

For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9;
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

題意:

長度爲n的a和b數列,想要將a後添加n個元素,添加的a數列滿足ai ≤max(aj-j), j滿足 bk ≤j<i,每個bk 只能拿一次求後添加的n個元素的和。

想法:

爲了使新增的每一個ai 最大,應該保證i越小時,aj 越大,bk 越小,這樣減數會越小。

所以我們先從後往前更新ai ,把越大的ai -i賦值給越小的i時的ai ,然後對b排序。
最後再取ai 時,拿ai 之前a中的最大值。

tips:
1.a,b數組開的時候要注意是開兩倍,因爲增加了n個元素
2.在最後取ai 的時候,取過的ai 也要減去i,當成已知的a中元素,max也在它存在時取。

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int a[510000],b[510000];//數組範圍要注意
const int mod=1e9+7;
int main()
{
    int maxn,n;
    while(~scanf("%d",&n))
    {
        maxn=-mod;
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a[i]);
            a[i]=a[i]-i;
        }
        for(int i=n;i>=1;--i)
        {//從前往後保證i min時取到最大的a max
            a[i]=max(a[i],maxn);
            maxn=max(a[i],maxn);
        }
        for(int i=1;i<=n;++i)
            scanf("%d",&b[i]);
        sort(b+1,b+n+1);
        long long ans=0;
        int j=1;
        maxn=-mod;
        for(int i=n+1;i<=2*n;++i)
        {
            a[i]=max(maxn,a[b[j]]);
            ans+=a[i];
            ans%=mod;
            a[i]-=i;//新取的元素用過後當成已知的元素
            maxn=max(maxn,a[i]);//新取元素用過後當成已知的元素一起更新最大值
            j++;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

ps:
做題時理解錯題意了+_+以爲是取aj -j和bk 中的max,結果不是【尬

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章