山東省第八屆acm省賽C題 fireworks

題目來戳呀

Problem Description

Hmz likes to play fireworks, especially when they are put regularly.
Now he puts some fireworks in a line. This time he put a trigger on each firework. With that trigger, each firework will explode and split into two parts per second, which means if a firework is currently in position x, then in next second one part will be in position x−1 and one in x+1. They can continue spliting without limits, as Hmz likes.
Now there are n fireworks on the number axis. Hmz wants to know after T seconds, how many fireworks are there in position w?
這裏寫圖片描述

Input

Input contains multiple test cases.
For each test case:
The first line contains 3 integers n,T,w(n,T,|w|≤10^5)
In next n lines, each line contains two integers xi and ci, indicating there are ci fireworks in position xi at the beginning(ci,|xi|≤10^5).

Output

For each test case, you should output the answer MOD 1000000007.

Example Input

1 2 0
2 2
2 2 2
0 3
1 2

Example Output

2
3

題意:
放煙花,在xi位置上有ci個煙花,1秒鐘一個分成兩個,前一個後一個,此位置上的就沒了。
一共有n個位置,問t秒後,在w位置上有多少個煙花。

想法:
寫幾組數據,用圖的形式展開來(不要緊巴巴的真的就在數軸寫啊+_+鬼能看出來啊)
某個位置上的圖寫出來發現類似楊輝三角,但是中間是加了0的
0 0 0 0 0 1 0 0 0 0 0
0 0 0 0 1 0 1 0 0 0 0
0 0 0 1 0 2 0 1 0 0 0
0 0 1 0 3 0 3 0 1 0 0
0 1 0 4 0 6 0 4 0 1 0
當所在的位置的奇偶性和時間的奇偶性相同時,發現符合楊輝三角。
符合楊輝三角的部分,即求組合數,C(n,m)=n!/m!(n-m)!,再對1e9+7取模;
因爲取模之前的結果太大了,所以我們通過乘法逆元的方法來求,即除以一個數等於乘以這個數的逆元再取模,這位的逆元寫的賊好
乘法逆元這裏選擇用快速冪的方法來求。
不符合楊輝三角的就是0。


#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll arr[100010];
void init()//求階乘
{
    arr[0]=arr[1]=1;
    for(int i=2;i<=1e5;++i)
        arr[i]=(arr[i-1]*i)%mod;
}
ll PowerMod(ll a, ll b)//快速冪
{
    ll ans=1;
    a=a%mod;
    while(b>0)
    {
        if(b&1)
            ans=(ans*a)%mod;
        b>>=1;
        a=(a*a)%mod;
    }
    return ans;
}
ll cn(ll n,ll m)
{
    return ((arr[n]*PowerMod(arr[n-m],mod-2))%mod*PowerMod(arr[m],mod-2))%mod;
}
int main()
{
    init();
    int n,t,w;
    while(cin>>n>>t>>w)
    {
        ll ans=0;
        while(n--)
        {
            ll ci,xi;
            cin>>xi>>ci;
            ll k=abs(w-xi);//求絕對值
            if((k&1)==(t&1)&&k<=t)//奇偶性相同就符合楊輝三角並且在時間範圍內
                ans=(ans+(ci*cn(t,(k+t)/2))%mod)%mod;
        }
         cout<<ans<<endl;
    }
    return 0;
}

ps: 哇卡哇卡不出來了QAQ

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章