HDU 1087 Super Jumping! Jumping! Jumping!【最長上升子序列元素總和】

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

這裏寫圖片描述

The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

題意:
求最長遞增子序列的元素總和。
想法:
n²的DP思想,先求出最長遞增元素總和,再在總和裏找最大值。和求長度一樣的想法。

#include <cstdio>
#include <algorithm>
#include <cstring>
const int MAX=1010;
using namespace std;
int seq[MAX];//代表此時的數
int seqlen[MAX];//代表能夠到達這個位置可達到的最大值
int main()
{
    int i,j,n;
    int sum;             //seqlen數組存以第i個數爲終點的最長上升序列總和
    while(~scanf("%d",&n),n)
    {
        for(i=1; i<=n; i++)
        {
            scanf("%d",&seq[i]);       //seq數組保存序列數組
            seqlen[i]=seq[i];
        }
         sum=seqlen[1];
        for (i=2; i<=n; i++)
        {
            for (j=1; j<i; j++)
            {
                if(seq[j]<seq[i])
                    seqlen[i]=max(seqlen[j]+seq[i],seqlen[i]);
            }
            sum=max(sum,seqlen[i]);
        }
        printf("%d\n",sum);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章