BestCoder Round #86

Price List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 97    Accepted Submission(s): 69


Problem Description
There are n shops numbered with successive integers from 1 to n in Byteland. Every shop sells only one kind of goods, and the price of the i-th shop's goods is vi.

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.
 

Input
The first line of the input contains an integer T (1T10), denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m (1n,m100000), denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains n integers v1,v2,...,vn (1vi100000), denoting the price of the i-th shop's goods.

Each of the next m lines contains an integer q (0q1018), denoting each number on Byteasar's account book.
 

Output
For each test case, print a line with m characters. If the i-th number is sure to be strictly larger than the actual value, then the i-th character should be '1'. Otherwise, it should be '0'.
 

Sample Input
1 3 3 2 5 4 1 7 10000
 

Sample Output
001

解題思路: 求出所有數的和sum ,如果q>sum 那麼肯定記多了。  

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 100050
int v[N];
int main()
{
    int T,n,m;
    long long t;
    scanf("%d",&T);
    while(T--)
    {
        long long sum=0;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&v[i]);
            sum+=v[i];
        }
        while(m--)
        {
            scanf("%lld",&t);
            if(t>sum)
                printf("1");
            else printf("0");
        }
        printf("\n");
    }
    return 0;
}


NanoApe Loves Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 164    Accepted Submission(s): 73


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.

Now he wants to know the expected value of F, if he deleted each number with equal probability.
 

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1T10, 3n100000, 1Ai109
 

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n.
 

Sample Input
1 4 1 2 3 4
 

Sample Output
6

解題思路:求出前i 個數裏相鄰差值的最大值f i  i n 裏相鄰差值的最大值g i  ,那麼ans= n i=1 max(|A i1 A i+1 |,f i1 ,g i+1 ) 。  

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 100050
long long INF=2000000001;
long long a[N],d[N];
int main()
{
    int T,n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%I64d",&a[i]);
        long long maxn=-INF,maxn1=-INF,num,num1;
        for(int i=2; i<=n; i++)
        {
            d[i]=a[i]-a[i-1];
            if(maxn<abs(d[i]))
            {
                maxn1=maxn;
                maxn=abs(d[i]);
                num1=num;
                num=i;
            }
            else if(maxn1<abs(d[i]))
            {
                maxn1=abs(d[i]);
                num1=i;
            }
        }
        long long sum=0;
        if(abs(d[2])==maxn) sum+=maxn1;
        else sum+=maxn;
        if(abs(d[n])==maxn) sum+=maxn1;
        else sum+=maxn;
        for(int i=2; i<n; i++)
        {
            long long l=abs(a[i-1]-a[i+1]);
            if(l>=maxn) sum+=l;
            else
            {
                if((num==i&&num1==i+1)||(num1==i+1&&num==i))
                    sum+=l;
                else if(num==i||num==i+1)
                    sum+=maxn1;
                else
                    sum+=maxn;
            }
        }
        printf("%I64d\n",sum);
    }
    return 0;
}


NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 152    Accepted Submission(s): 72


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.
 

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

Output
For each test case, print a line with one integer, denoting the answer.
 

Sample Input
1 7 4 2 4 2 7 7 6 5 1
 

Sample Output
18
解題思路:這題可以考慮尺取法,將不小於m 的數看作1 ,剩下的數看作0 ,那麼只要區間內1 的個數不小於k 則可行,正好可以使用尺取法

#include<iostream>
#include<cstdio>
#include<cstring>
#include<set>
#include<map>
using namespace std;

const int maxn = 200005;
int n,m,k;
int a[maxn],sum[maxn];

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&k);
		for(int i = 1; i <= n; i++)
		{
			scanf("%d",&a[i]);
			sum[i] = sum[i-1];
			if(a[i] >= m) sum[i]++;
		}
		int i,j = 1;
		long long ans = 0;
		for(i = 1; i <= n; i++)
		{
			while(sum[i] - sum[j-1] >= k)
			{
				ans += n - i + 1;
				j++;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}



發佈了395 篇原創文章 · 獲贊 2 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章