1097 Deduplication on a Linked List (25分) 簡單靜態鏈表題 20minKo

1097 Deduplication on a Linked List (25分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
#include<iostream>
#include<algorithm>
#include<vector>
#include<set>
#include<cmath>
using namespace std;
struct node{
	int add,v,next;
};
node a[100010];
int main()
{
	int i,j,ts,n,len;
	node t;
	set<int> b;
	vector<node> k,r;
	b.clear();
	k.clear();
	r.clear();
	cin>>ts>>n;
	for(i=0;i<n;i++)
	{
		cin>>t.add>>t.v>>t.next;
		a[t.add]=t;
	}
	for(i=ts;ts!=-1;ts=a[ts].next)
	{
		if(a[i].v!=0)
		{
			if(b.count(abs(a[ts].v))==0)
			{
				b.insert(abs(a[ts].v));
				k.push_back(a[ts]);
			}
			else
			{
				r.push_back(a[ts]);
			}
		}
		
	}
	
	for(i=0;i<k.size();i++)
	{
		if(i!=k.size()-1)
		printf("%05d %d %05d\n",k[i].add,k[i].v,k[i+1].add);
		else
		printf("%05d %d -1\n",k[i].add,k[i].v);
	}
	for(i=0;i<r.size();i++)
	{
		if(i!=r.size()-1)
		printf("%05d %d %05d\n",r[i].add,r[i].v,r[i+1].add);
		else
		printf("%05d %d -1\n",r[i].add,r[i].v);
	}
	return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

發佈了383 篇原創文章 · 獲贊 109 · 訪問量 22萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章