POJ 1159 [IOI2000] Palindrome

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5

Sample Output

2

Source

IOI 2000

給定一個串的長度和一個串,求最少添加幾個字符使這個串變成一個迴文串。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

short dp[5002][5002];
char aa[5002], b[5002];

int main()
{
    int n;
    scanf("%d", &n);
    scanf("%s", aa + 1);
    for(int i = 1, j = n; i <= n, j >= 1; i++, j--)
        b[j] = aa[i];
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
        {
            if(aa[i] == b[j])
                dp[i][j] = dp[i - 1][j - 1] + 1;
            else 
                dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]); 
        }
    printf("%d", n - dp[n][n]);
    return 0;
}   
發佈了62 篇原創文章 · 獲贊 4 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章