Roads in the North POJ - 2631(树的直径)

Roads in the North
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2992   Accepted: 1477

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

Source

题目大意:给你多个两点之间的权值,然后求一个最长路

解题思路:求出来树的直径就可以了,我一开始想的是权值为负,求最短路,emmmmm

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

vector<int> tu[50005],lu[50005];
int check[50005],dis[50005],n,MAXN;
void build(int x,int y,int l)
{
	tu[x].push_back(y);
	lu[x].push_back(l);
}
int dfs(int x)
{
	int tot,k,l,index;
	memset(check,0,sizeof(check));
	memset(dis,0,sizeof(dis));
	tot=0;
	MAXN=0;
	queue<int> qua;
	qua.push(x);
	check[x]=1;
	while(!qua.empty())
	{
		k=qua.front();
		qua.pop();
		for(int i=0;i<tu[k].size();i++)
		{
			index=tu[k][i];
			l=lu[k][i];
			if(check[index])
				continue;
			check[index]=1;
			qua.push(index);
			dis[index]=dis[k]+l;
			if(dis[index]>MAXN)
			{
				MAXN=dis[index];
				tot=index;
			}
		}
	}
	return tot;
}
int main()
{
	int i,x,y,l;
	while(cin>>x>>y>>l)
	{
		build(x,y,l);
		build(y,x,l);
	}
	int t=dfs(1);
	int tot=dfs(t);
	cout<<dis[tot]<<endl;
 return 0;
}


发布了149 篇原创文章 · 获赞 5 · 访问量 4万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章