Just a Hook HDU - 1698(線段樹區間更換,區間詢問模板)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35101    Accepted Submission(s): 17147


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1 10 2 1 5 2 5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye
 

題目大意:一開始每個線段的權值爲1,現在給多次修改,將一個區間內的值統一修改一下,然後詢問1到N區間和
解題思路:線段樹的區間更改,區間詢問
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

const int MAXN=1e5+5;

struct tree
{
	int flag;
	int sum;
}a[MAXN*4+5];
int n,m,T;
void pushup(int deep)
{
	a[deep].sum=a[deep*2].sum+a[deep*2+1].sum;
}
void pushdown(int deep,int longs)
{
	if(a[deep].flag)
	{
		a[deep*2].flag=a[deep].flag,a[deep*2+1].flag=a[deep].flag;
		a[deep*2].sum=(longs-longs/2)*a[deep].flag;
		a[deep*2+1].sum=longs/2*a[deep].flag;
		a[deep].flag=0;
	}
}
void build(int l,int r,int deep)
{
	a[deep].flag=0;
	if(l==r)
	{
		a[deep].sum=1;
		return;
	}
	int mid=(l+r)/2;
	build(l,mid,deep*2);
	build(mid+1,r,deep*2+1);
	pushup(deep);
}
void update(int L,int R,int k,int l,int r,int deep)
{
	int mid=(l+r)/2;
	if(L<=l&&r<=R)
	{
		a[deep].flag=k;
		a[deep].sum=(r-l+1)*k;
		return;
	}
	pushdown(deep,r-l+1);
	if(L<=mid) update(L,R,k,l,mid,deep*2);
	if(mid<R) update(L,R,k,mid+1,r,deep*2+1);
	pushup(deep);
}
int query(int L,int R,int l,int r,int deep)
{
	if(L<=l&&r<=R)
	{
		return a[deep].sum;
	}
	pushdown(deep,r-l+1);
	int mid=(l+r)/2;
	int sum=0;
	if(L<=mid) sum+=query(L,R,l,mid,deep*2);
	if(mid<R) sum+=query(L,R,l,mid,deep*2+1);
	return sum;
}
int main()
{
	int k=0;
	int i,x,y,sum;
	scanf("%d",&T);
	while(T--)
	{
		k++;
		scanf("%d",&n);
		scanf("%d",&m);
		build(1,n,1);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&x,&y,&sum);
			update(x,y,sum,1,n,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",k , query(1,n,1,n,1));	
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章