HDU - 2594 Simpsons’ Hidden Talents(KMP)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10068    Accepted Submission(s): 3486


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
clinton homer riemann marjorie
 

Sample Output
0 rie 3
 

Source
 

Recommend
lcy
 

Statistic | Submit | Discuss | Note

題意:求A串前綴和B串後綴的最長相同串
#include <bits/stdc++.h>
using namespace std;

const int N = 1e6 + 10;
int t, n, m;
int la, lb;
char a[N], b[N];
int nex[N];

void get_nex(){
    int i = 0, j = -1;
    nex[0] = -1;
    while(i < la){
        if(j == -1 || a[i] == a[j]){
            i++, j++;
            nex[i] = j;
        }
        else j = nex[j];
    }
}

int main(){
    while(~scanf("%s%s", a, b)){
        la = strlen(a);
        a[la] = '#';
        a[la+1] = '\0';
        strcat(a, b);
        la = strlen(a);
        get_nex();
        if(nex[la]){
            for(int i = 0; i < nex[la]; i++){
                printf("%c", a[i]);
            }
            printf(" %d\n", nex[la]);
        }
        else printf("0\n");
    }
}


發佈了133 篇原創文章 · 獲贊 5 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章